Errors? Check for Browser and Java Issues

Issue: Errors accessing content, uploading files

These are usually symptoms of a problem with your browser, Java and/or your cache(s). If you experience any of these, please follow the steps below to make sure your browser and Java are compatible with Blackboard, clear your browser cache and make sure Java is configured correctly.

If your problem persists contact:

Blackboard Technical Support Help Desk

Call (515) 294-4000 to speak directly with a Solution Center technical support agent. For assistance outside Solution Center hours, complete this online help request form and a Solution Center agent will respond to your request.

Important Note for Students

If you get a message that you do not have permission to access course content or activities (e.g. Tests, Discussions, Assignments, etc.), or they are unavailable, contact your Instructor.

1. Make Sure You Are Using a Supported Browser

See list of Supported Browsers.

Visit the Blackboard’s Browser Checker website or use the “Browser TestBrowser Test” tool on the MyISU tab in Blackboard (generally found on the bottom left corner).

2. Clear Your Browser Cache

Internet Explorer

  1. Open the Tools menu.
  2. Select Internet Options.
  3. Under Browsing History, click Delete.
  4. Click Delete All.
  5. Click Ok.
  6. Shut down and restart the browser.

Firefox

  1. Select Clear Recent History from the Tools menu.
  2. Check the box next to Cache (deselect other boxes if you do not want to delete that information too).
  3. Choose the time frame.
  4. Click Clear Now.
  5. Shut down and restart the browser.

Safari

  1. Open the Safari menu.
  2. Select Empty Cache.
  3. Click Empty.
  4. Shut down and restart the browser.

Chrome

  1. Click the wrench icon on the browser toolbar.
  2. Select Tools.
  3. Select Clear browsing data.
  4. In the dialog that appears, select the checkboxes for the types of information that you want to remove.
  5. Use the menu at the top to select the amount of data that you want to delete. Select beginning of time to delete everything.
  6. Click Clear browsing data.

3. Check Java / Clear Your Java Cache

Java For Mac Users: Clear Java Preferences Cache

    1. Open the Finder and navigate to Applications.
    2. Open the Utilities folder and open Java Preferences.
    3. Click on the Network tab.
    4. Click Delete Files . . . and click OK.
    5. Quit the application and restart your browser.

Java for Windows

  1. Delete all incompatible versions of Java
    1. Windows: From the Start menu, click Control Panel.
    2. Double-click Add/Remove Programs . . . or Programs and Features.
    3. Locate all versions of Sun Java, JRE, or JVM.
    4. For each version, click Change/Remove and follow the onscreen instructions.

    If you are using Windows 2000 or a version of Windows XP upgraded from 98/2000, make sure the original Microsoft Java VM is disabled in IE 6.0. Go to Tools > Internet Options > Advanced.

  2. Install the recommended version of Java. Download Java for Windows.
    1. Download Java.
    2. To install Java, accept the license agreement and follow the online and onscreen instructions. After installing Java (aka JRE) and rebooting your computer, do not download updates for the Java.
    3. Clear the Java applet cache in the Java Control Panel. Log out of Blackboard before doing this.
      1. From the Start menu, click Control Panel.
      2. Double-click the Java coffee-cup icon labeled Java Plug-in or Java to launch the Java Plug-in Control Panel.
      3. In the General tab, in the section labeled Temporary Internet Files click the Delete Files button.
    4. While you are in the Java Control Panel, Disable automatic checking for Java updates:
      1. Click the Update tab.
      2. Deselect the checkbox next to Check for Updates Automatically.
      3. Then click OK to exit the window.
    5. Clear the browser cache.